Outage earlier this week

Okay, that sucked — you may have noticed that this blog has been down since late Sunday night, or showed my corporate website instead of the blog. I’m constantly amazed at the ways that domain registrars and hosting providers can screw things up; there’s always some new frustration. I’m documenting the whole story here for posterity — and maybe to help other people in the same position in the future — but if you’re not interested in technical details of domain transfers, move on.

It started around 2am Monday morning, when I couldn’t sleep and decided to start a project that I’ve been thinking of for a while: transferring my corporate domain, which includes my website and my primary email address, from Yahoo to GoDaddy. I love Yahoo’s webmail, but I’ve become frustrated with their implementation of MySQL and WordPress, which is anything but standard. I’ve been using GoDaddy for both this blog and my wine club site/blog for quite a while, and am happy with their registrar services, their hosting and their prices.

Easy peasy, right? Not so much. First, I go to Yahoo and unlock my domain — first step in starting any domain transfer. Then, over to GoDaddy and initiate the transfer. I get the email from GoDaddy with the Transaction ID and Security Code, pick up the Authorization Code from Yahoo’s domain management page for my site, and enter it all in on GoDaddy, which is supposed to be everything that I need to do, except wait. So I wait. Now, I’m a bit impatient about technology sometimes, but every domain transfer that I’ve ever done before has happened automatically, and therefore within an hour or two has switched over. Which means that I was a bit surprised to find that 12 hours after initiating the transfer, my domain was still sitting as a pending transfer in GoDaddy with a status of “Pending Current Registrar Approval”. Basically, that means that although I’ve initiated the transfer and provided all required approvals and security information to complete the transfer, the current registrar is sitting on the transfer.

Meanwhile, I replicated my corporate website on GoDaddy (which explains, in a roundabout way, why this blog was down — I’m hosting both under the same hosting account, and I wanted to make my corporate site the primary site, so had to relocate this domain as a secondary domain on the account, which takes some time) so that when the transfer finally came through it would be available, and I changed my MX records over on Yahoo to redirect my mail to a new mail account that I set up on GoDaddy for my corporate mail. Mail started arriving on GoDaddy instead of Yahoo, but still the domain transfer waited.

This morning, more than 24 hours after initiating the domain transfer, I called Yahoo technical support. “Walter” informed me that Yahoo is not the reseller of my domain (huh? then how come I paid Yahoo for my hosting/domain services?) but that I have to contact the registrar, Melbourne IT, directly — in Australia! Okay, this is starting to bite.

I went on Melbourne IT’s site and tried to their password recovery for my domain (which presumably would email a password to me as the domain’s contact), but was presented with:

Retrieval Failed

The Registry Key for Domain Name kemsleydesign.com was not able to be retrieved. This could be due to the Domain Name being managed by a Melbourne IT Reseller. Please contact your Reseller for assistance.

Hmmm. I went off to their help pages, then their contact pages and eventually found a customer service request form, where I tried to be as succinct as possible:

I am attempting to transfer my domain, kemsleydesign.com, from Melbourne IT to  GoDaddy, but it appears to be stuck in the status “Pending Current Registrar Approval”. I have entered the appropriate authorization code that should release the domain, but it has been in this status for more than 24 hours. Can you please confirm that this transfer is pending and will occur soon?

By this time, it’s midnight in Australia and (given the current state of things), I’m not expecting a real speedy answer, so I was impressed to receive a reply within the hour:

Subject: How to contact your domain manager for kemsleydesign.com


A Melbourne IT Reseller manages the domains specified in your message.

Please contact this reseller using the details below for any assistance you require. If the person you contact refers you back to us, ask them if they would please contact us on your behalf.

Reseller details:

Yahoo Inc.
Web address: domains.yahoo.com
Email address: [email protected]

If after 48 hours you have yet to obtain a satisfactory response:


Please provide us as much detail of any correspondence with the reseller which relates to this request.

Please note: In an effort to resolve this matter quickly we will notify the Reseller of this request including any details you have given us.

Kind Regards,
Melbourne IT Customer Support


The status of your case is now closed.

If you need to reopen this case with additional information, please reply to this email. If you need to contact Melbourne IT by phone please quote this case ID

Okay, someone is obviously confused: either Yahoo is the reseller and their technical support people don’t know it, or they’re not and Melbourne has their records screwed up. In either case, they both appear to be refusing to give me technical support for this, which lends credence to my argument that they’re just trying to delay in hopes that I’ll forget about it.They don’t know how stubborn I am (they should ask Netfirms).

I check the WHOIS information (again) and notice that Melbourne IT is indeed listed as the registrar, although I’m not sure if the reseller’s name normally appears on WHOIS along with the registrar. I replied to Melbourne IT, hoping to eventually get a human to look at this:

Yahoo customer service informed me that they are NOT A RESELLER, and that I must contact Melbourne IT directly for assistance with my domain. Melbourne IT is listed as the registrar on the WHOIS record for this domain. Please confirm that the domain transfer to GoDaddy.com is in progress.

Then, I fired off two emails to Yahoo, one telling them not to renew my domain (which they were planning to do later this week as part of my hosting package since it comes up for renewal next month), and the following which included Melbourne IT’s message to me:

Earlier this morning, Yahoo technical support told me (on a phone call) that Yahoo is NOT a reseller of domains, and that I have to contact the registrar, Melbourne IT, directly with my current problem with my domain kemsleydesign.com. However, Melbourne IT states quite clearly in the attached email that Yahoo is in fact the reseller for this domain and that you should be dealing with my technical support problems.

I am attempting a domain transfer away from Yahoo to GoDaddy, which was initiated more than 24 hours ago. My domain appears to be stuck in “Pending Current Registrar Approval” status, although I have entered the transfer Transaction ID, Security Code and Authorization Code from the GoDaddy site as required. Can you please confirm that this transfer is underway?

Meanwhile, over on GoDaddy, the hosting account finally accepted the switch from this blog domain to my corporate domain as the primary domain for the account, and I could initiate adding the blog domain as a secondary domain. This, however, takes a few hours so this blog address went from displaying my corporate website (bad) to displaying a GoDaddy parked domain page (worse). My own fault — I could have left this blog as the primary domain and added my corporate one as a secondary — but I thought that the switch would happen within minutes, not more than 24 hours. By now, I was unhappy with Yahoo, Melbourne IT and GoDaddy, and ready to go back to chiseling blog entries on stone tablets.

I searched around for other people with this problem, and found a few. In fact, I even found a document from GoDaddy specifically talking about transfers from Melbourne IT, so they must have seen this problem before. They state that it could take 5 days, since once GoDaddy requests the transfer at the registry, if Melbourne IT doesn’t respond to the registry’s request to approve/deny the transfer, new ICANN rules automatically approve it after five days. In other words, Melbourne IT probably just ignores requests for transfers and waits for them to time out; they’ve had their wrists slapped by ICANN for sloppy practices in the past when they abdicated responsibility during domain transfers to their resellers (although there is definitely dissent between Yahoo and Melbourne IT about whether Yahoo is actually a reseller). I realize that at this point, I’m about to become an ex-customer of Melbourne IT and they may not be fully motivated to serve my needs, but this is an incredibly poor bit of customer service.

This blog address finally sorted itself out around midday today. Stay tuned for more on the domain transfer.

2 Replies to “Outage earlier this week”

  1. I came across this post in a Google Search for problems with Yahoo domains being stuck in pending status. Although I notice this post is almost 2 years old at this point I thought I’d leave a note to say that the problems you described are apparently still common. I have a domain I am trying to simply point to new nameservers and I can’t do that because Yahoo has the domain stuck in pending status and all the options are grayed out. The domain has apparently been in pending status for MONTHS, but I am just now noticing it because this is the first time I’ve needed to make any changes. As you describe in your post, Yahoo refers me to Melbourne IT and vice versa so neither of them takes any action and I have yet to make any progress.

    I guess the only thing to be done is for people who have been through these kind of experiences to get the word out as much as possible that webmasters should not be handing their money to the sharks at Yahoo and Melbourne IT and their little scam. I’m not real happy with how Yahoo does not disclose all of the relevant information about their pricing either, but that’s a whole other matter.

Leave a Reply