I love the internet

It’s not even 9am, and I’ve had an “I love the internet” moment. Two nights ago, I was helping a friend to work out a few Blackberry problems, one of which was that her browser icons disappeared from the main screen after a recent reinstall. She doesn’t use the browser a lot, but I had set it up previously for her with some bookmarks for local weather and the movie times are her favourite theatres, so it was definitely an inconvenience not to have it. At the time, I just downloaded and reinstalled software from the Rogers site and re-synched her device, and the icons magically reappeared — I really hate when that happens.

Last night, I decided to check if there was an upgrade on the Rogers site for my Blackberry, and sure enough, I could move from my current OS 4.0 to the newer 4.1. I figured that it would be a 15-minute job to do while I was running my regular backup, but it turned out to require several device restarts and a complete backup and restore of all data and applications in “snail pace” mode, taking more like 1-1/2 hours. When I was done, no browser icons. Shit.

It was late, I went to bed, but the first thing that I did this morning was to Google “blackberry browser icons disappear after software upgrade”, figuring that I couldn’t be the only person with this problem. Sure enough, the first search result was an entry in the BBHub Blackberry blog (a site that I didn’t previously know about) discussing someone else with the identical problem. Their solution was to suggest Opera Mini (which I don’t really like, although I’m now giving it another try), but they linked through to the original forum conversation that spawned this post over on the Pinstack Blackberry forums (another site that I didn’t know about, free registration required). The 6th post in the thread solved my problem:

I’m sure the Cingular rep had you do this, but the option for register now in version 4.1 is under Options > Advanced Options > Host Routing Table. Pick an entry in that list, click and choose Register Now. That should bring back the Cingular Browser or mMode, as well as the Internet Browser.

Host Routing Table? Register Now? Tried it, it worked like a charm, problem solved.

Anything that saves me having to actually call Rogers customer service is reason enough to love the internet.

Leave a Reply